Simon Harrer and I talk about the chapter “Name Things Right” from his book “Java by Comparison”.
In this video, we talk about avoiding meaningless terms: Terms that are redundant (like “Service”, “Manager”, “Util”), but also weak terms like “invokeTask”. By removing those terms from our code, we can make our software easier to read and understand for the next programmer.
Check out the video to learn more! Further reading:
Read / watch all parts of this series here: